Announcement

Collapse
No announcement yet.

4Duino complile problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4Duino complile problem

    Hello,

    I've been using 4Duino for a long time, but yesterday I couldn't compile my program (the code works well)

    4D Workshop and arduino also gives me this error:
    cc1.exe: error: -fno-fat-lto-objects are supported only with linker plugin.

    what can be the solution?

    regards,
    Tamas

  • #2
    Hello Tamas,

    May I know what version of Arduino IDE you're using?

    I'm currently using 1.8.8 and I don't seem to be having this issue, could you please try to update to 1.8.8 and see if that solves the issue?
    Michael

    Comment


    • #3
      I'm currently using the 1.8.5, but as you advised I updated the latest version (1.8.8) but the problem is still the same

      Comment


      • #4
        Hello Tamas,

        This seems really odd.

        Could you please ensure that the error is not coming from other libraries?

        This forum thread seems to have discussed a similar issue and it was caused by an incompatibility with another library.

        Newbie: Support for 4Duino hardware does not appear...
        https://forum.4dsystems.com.au/node/60714

        Best regards,
        Michael

        Comment


        • #5
          It seems that the problem is solved.
          I deleted "AppData\Local\Arduino15" folder then I tried to compile again, everything is working fine.

          Thank you Michael!

          Comment

          Working...
          X