No announcement yet.

Gen4 43 DCT Screen Freeze - Vertical lines

  • Filter
  • Time
  • Show
Clear All
new posts

  • Gen4 43 DCT Screen Freeze - Vertical lines


    I'm using a 43DCT on 10 instruments. Rx-Tx with µC serial command.
    After a time I get, sometimes, freezing screen and vertical lines.
    The Touch Screen is freezed until its power-down and up.

    Could you tell me what's happening and how to avoid that embarrassing problem for user ?

    I really thank you for your help and any ideas to help me.

    Here is a picture of the Screen when failing :
    Click image for larger version

Name:	ScreenFreeze.jpg
Views:	97
Size:	304.9 KB
ID:	67415

  • #2

    Thank you for purchasing our product.

    This may be a weird issue as many of our customers use the 4D Display for a long period of time.

    Can I ask how are you powering the display?

    Have you tried to power-up/boot the display individually? Without any serial communication from the host.

    Also, does the problem happens on all of the units that you bought?

    Best Regards,


    • #3
      Hello Kevin,

      Thank you for your reply !!

      We have that issue on 5 differents instruments.
      We are using a stepper motor on it and I'm looking for EMC ferrite protection on RX-TX cable.
      I'm using the standard flat cable with the little Red PCB to the multicolor cable 16cm long 4D Systems.
      It's powered by this multicolor cable with 5V generated from 24V PSU shared with the motor.
      I've added 10µF capacitor on the Red PCB betwin +5V and GND and 10µF on my 24V but the issue occured again.

      Would you have some more ideas to test ?

      Thank you,


      • #4
        I've added a 2200µF on the 24V and until now do not have to face to any issue.
        I'm testing more and more.


        • #5

          The issue occured again.
          I saw the screen slowly fading (more than 10 seconds) from original Form to that grilled screen.
          The touch screen and buttons are no more visible but still Reporting messages and active...

          Quite strange.

          Any ideas ?


          • #6
            I seen in my PCB that the Reset pin and its wiring is floating.
            I'm going to pull it up (or down I don't remember) and test it tomorrow.


            • #7

              It looks like you have a complex design for your project and I may not be able to duplicate your current setup.

              You can try to isolate the display and power it using a different power source (e.g micro USB cord connected to a computer's USB port)
              to ensure that no power surges occur which may cause the issue.

              Another issue which causes the 'freezing' of the display can be incompatible USD card or improper handling of ACK/NACK.

              For a similar inquiry, you can check these two forum threads:


              Best Regards,
              Last edited by John Kevin; 13th March 2019, 04:22 PM.


              • #8
                Hello Kevin,

                Thank you for this informations and topics linked to my issue.
                I'm going to check it.

                I'm using Class 10 µSD and my issue is reproducible between different same instruments.


                • #9
                  Here is some updates.

                  I haven't already find the causes and the solution.

                  What didn't worked :
                  - 10µF on 5V Pin of 4D red PCB
                  - 2200µF on my 24V PSU (before 5V conversion)
                  - 10k Pull Up beetween 5V and RST pin on 4D red PCB

                  I'm using 43DCT on 19200bd, µSD class 10.

                  I'm going to try ferrite core on the multicolor cable but have no more ideas after this...


                  • #10
                    Class 10 uSD means nothing when used in 4D Modules.
                    4D Modules use SPI communication to the SD cards, not SD Bus, so the speed rating is N/A.
                    What you must ensure is the card you are using is SPI compatible, as many modern cards do not follow these standards.
                    Can you provide more information on what your SD card is? Brand/Make/Model/Size etc.
                    There is also a uSD Tester application found in the Tools Menu of WS4 when you have your project open. This might show something, if you can post the output of that.
                    I am not certain if the issue you are seeing is related to the Card or not, as in theory if the card is loosely SPI compatible but when put under stress it fails, you could see corruption, but I don't believe we have seen anything quite like this.

                    Please ensure the locks on the display FPC are securely closed too.
                    How many modules are you seeing exhibit this issue?
                    How many use the same SD card(s)?

                    Are you able to set up a display on the same power supply, with an application which does not use the SD Card, to see if it fails in the same way?

                    This is quite an unusual case.



                    • #11
                      Hello James,

                      Thank you for you complete answer on SD topic.
                      I'm going to test the SD card. It's all the same SD card Sandisk, used for some other products and on our production and we haven't this issue.
                      So more linked on our new instrument or the way to produce that new instrument or the software that is different.

                      We also had that same issue on different instrument at nearly the same moment.

                      I'm going further on :
                      - Testing SD card
                      - Check SD partition and setup (same partner then before who did the job so we will see)
                      - Checking complete software to see if no overflow would be created

                      What didn't worked :
                      - Ferrite core on multi Color Cable
                      - 10µF on 5V Pin of 4D red PCB
                      - 2200µF on my 24V PSU (before 5V conversion)
                      - 10k Pull Up beetween 5V and RST pin on 4D red PCB


                      • #12
                        I tried :
                        µSD Tester
                        Note: 0 Button Animation Timers in use.
                        0 errors
                        0 warnings
                        3 notices
                        No Errors, code size = 13899 bytes out of 32750 total
                        Approximate run RAM size = 14326 bytes on 32768 total (Base :756 Disk:38 Strings:570 Img+Font_Controls:1734 Img_elements:11228)

                        I tried a special software that is always send write command to the touch screen, all the time, 100µs between frames.
                        The Touch Screen didn't failed after 1 hour. So I think my original software isn't creating that issue.

                        I'm testing Old Serial n° TS.
                        I'm testing other SD cards.


                        • #13
                          Old Serial n° Touch Screen doesn't avoid the issue (under 19020590).
                          Old µSD card (same model but no issue in the past on other devices) doesn't work.

                          I was using Run on µSD card Bank 1.
                          I'm testing on Run Flash mode (.4xde on Touch Screen's flash and not on SD card).
                          Last edited by s.schroeders; 15th March 2019, 02:09 AM.


                          • #14
                            The vertical lines on the display tend to indicate an error 'after' Diablo, so, as James said, check that the FPC connection to the board is properly inserted and latched properly.

                            Also, is it possible there is some static, or other interference that could be causing the display itself to lock up and do this? (Since you mentioned two failures at nearly the same moment)

                            I think you said you can still communicate with Diablo serially, if so, maybe add a command to do a disp_Init() to see if that clears the display up and allows progression.

                            Are you loading and running programs off uSD? Maybe there is a uSD read error that is resulting in a garbage program that is being loaded.

                            Or, since you appear to be using 'normal' uSD cards (as opposed to the recommended Industrial grade cards) which might be causing read errors courtesy of 'Read Disturb'.

                            Try running the attached program for approx 1/2 an hour or so. After starting immediately start a terminal Window. The display should normally just say 'Starting', if Es and Xs appear this indicates errors, the terminal window will have more indication of the sort of error.
                            PmmC will timeout read at 100ms
                            00:00:13 Starting
                            00:01:07 15ms for read 000056157
                            00:01:14 65ms for read 000063651
                            00:01:14 100ms for read 000063652
                            File Error 26 on read 000063652 reiniting
                            00:01:14 64ms for read 000063653
                            00:01:15 100ms for read 000063654
                            File Error 26 on read 000063654 reiniting
                            This is from the terminal Window, a normal card will only display the first two lines.
                            These sorts of errors are not 'Read Disturb', they are basically 'cheap' cards, if you try reporting it to the manufacturer they will tell you to use industrial cards.

                            It's a bit harder to see 'read disturb' without a specialised setup, but if it is really bad, simply comparing the files on the card to the original on your PC will report errors. (comparing multiple times might or might not achieve anything, as it depends on whether Windows rereads from the card, or more likely, simply reads from an in memory buffer)

                            Attached Files


                            • #15
                              Thank you for you deep answer.
                              It gives me new way to see my issue.
                              I'm going further with that.

                              The testings of this night it telling me that an overheating issue of the Touch Screen is possible.
                              I have an instrument running for more than 48h without any issue with brightness at middle (7).
                              I turned it to the maximum (15) and the issue appeared in less than one hour...