Announcement

Collapse
No announcement yet.

New user need help -gen4-uLCD-70DT-AR

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New user need help -gen4-uLCD-70DT-AR

    I inherited code from other SW engineer who left the company. I can compile the code without error, but I don't see the display when connect to serial port to read the data. I only compile to Flash. I have tried to load to RAM, but it doesn't seem to make difference. I also try to update u_SD and didn't find way to write to it in the workshop. I copy a backup version on PC directly to u_SD. It doesn't seem help either. Any idea what I need to do? Hope to get someone to help me. Thanks

  • #2
    Hi TheLawlz, I am a beginner and looking for help. When I put in the u_SD to the display unit, I don't see the UI design (the display image is not loaded). When I open the source code, I can see the design. Do you know why? Thanks

    Comment


    • #3
      Hello Jojo,

      Have you had a chance to read this Application Note?

      ViSi-Genie Getting Started - First Project for Diablo16 Display Modules
      https://www.4dsystems.com.au/appnote/4D-AN-00106/

      Best regards,
      Michael

      Comment


      • #4
        Hi Michael, Thank you so much for replying.... I have been looking for help whole day! I have gen4-uLCD-70DT-AR though. Do you have the app note URL for this product?
        Thanks!

        Comment


        • #5
          Hi Michael, I noticed the 70DT is included in the app note. I inherited the code from other SW engineer who already left the company. I load and compile the known working code to a new 70DT devise, but I can't get it work. Funny thing is that the menu for u_SD does not show up in my workshop. I don't know why.

          Comment


          • #6
            Sorry... I am VERY new to this. The set up I received uses gen4-PA, not the 5 pin devise. When I plug the u_SD to my computer, the SD icon does NOT show up in the Comms menu.

            Comment


            • #7
              Hello,

              I need to know which environment you are working on, is it ViSi-Genie or ViSi environment?
              This is important for us to determine what exactly is causing the problem and suggest
              a solution based on your chosen environment.

              "When I put in the u_SD to the display unit, I don't see the UI design (the display image is not loaded)"
              This happens usually when you did not copy the GCI files into your microSD card. Please check
              your microSD card if the image files(.GCI and .DAT) are copied.

              How do you upload your project into the display?

              Please check this quick start guide to help you set-up your project properly:
              QUICK START GUIDE for gen4-uLCD-70DT-AR

              Best regards,
              Sherwin
              Last edited by sherwin4D; 30th April 2019, 02:04 PM.

              Comment


              • #8
                Hi Sherwin, Thank you for the info. I believe that I use ViSi environment. Yes. I do have both .GCI and .DAT on the SD.

                Comment


                • #9
                  BTW, Sherwin, I did follow the steps in the 70DT app note. I only can see the display when I connect to the computer, but the display doesn't start when I connect the devise to the actual envi for usage. We use this display to show various data from a serial port. Do you know how to test the serial port in the dev envi? I am guessing that it is possible that the serial input having issue. Thanks

                  Comment


                  • #10
                    So, a quick question.
                    Is your uSD card formatted correctly? It needs to be FAT16 file system.
                    One way to check is to put the uSD card into the touchscreen, connect the touchscreen to your computer, open Workshop and select your touchscreen's comm port.
                    ** The uSD MUST be in the touchscreen for this part **
                    Then, go to the "Tools" tab and click on the "uSD Tester" option in the Top Left of the Workshop program window.
                    This will then quickly download a little "diagnostic program" onto your 70DT. This program will then print off a lot of info (onto the touchscreen) about the uSD card.
                    In the 2nd "paragraph/block" of green text, it will tell you the partition type, which should be "Partitioned FAT 16".
                    If it's not FAT16, then take the uSD card out of the touchscreen and put it into the computer. Now go back to the "Tools" menu in Workshop and use the RMPet to format the uSD:
                    https://forum.4dsystems.com.au/node/3901

                    And I am assuming you have this little tidbit near the beginning of your program:
                    Code:
                    // Mount the drive
                    if (!(file_Mount()))
                        while(!(file_Mount()))
                        wend
                    endif // End mounting

                    Comment


                    • #11
                      Yes. I assume the uSD was format correctly because it worked before customer break the display unit.

                      Comment


                      • #12
                        Hi TheLawiz, Yes. I have a similar code. See below:
                        /Quick check to make sure the uSD card is there....
                        putstr("Mounting disk...");
                        if (!(file_Mount()))
                        gfx_Cls();
                        txt_Set(TEXT_COLOUR, 0xF800); //RED:5, GREEN:6, BLUE:5
                        while(!(file_Mount()))
                        putstr("Disk is missing or malfunctioning!\n");
                        putstr("Seek service as soon as possible.\n");
                        pause(1000);
                        gfx_Cls();
                        wend
                        txt_Set(TEXT_COLOUR, 0x07E0); //RED:5, GREEN:6, BLUE:5
                        else
                        putstr("done.\n");
                        endif

                        Comment


                        • #13
                          Hi Everyone, I traced the code and found the mounting of uSD , loading config and GUI without any issue. What might be the root causes for the devise not showing the GUI image? Thanks

                          Comment


                          • #14
                            Hi Jojo,

                            Thanks for the clarification.

                            Do you have this line code?
                            Code:
                            hndl := file_LoadImageControl("ProjectName.dat", "ProjectName.gci", 1);
                            This should be on your code albeit by default, it's commented out.

                            Other root cause I could think of is, your "ProjectName.dat", and "ProjectName.gci" doesn't match
                            the compiled *.DAT and *.GCI file on your project folder, so, I think you should check whether they are the same.

                            If you don't mind, you can upload your project file here, so I could take a look further and give you
                            other solution/s. If you think your project is confidential and can't exactly share the code publicly,
                            you may send it via PM or email.

                            Here's my email add: sherwin.macabio(at)4dsystems.com.au
                            Just replace (at) with "@"

                            Hope this helps and best regards,
                            Sherwin
                            Last edited by sherwin4D; 2nd May 2019, 10:44 AM.

                            Comment


                            • #15
                              Yes. I have code : hndl := file_LoadImageControl("BMSinter.dat", "BMSinter.gci", 1); But I think my project name is BMSinterface on the workshop. However , the generated files are all having "BMSinter" name. Will zip up the project and email to you now. Thanks

                              Comment

                              Working...
                              X