Announcement

Collapse
No announcement yet.

Serial works in GTX but not RealTerm

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Serial works in GTX but not RealTerm

    Hello,

    I am working with the gen4-ulcd-28DT. I have created a simple GUI using Visi-Genie (free version) that makes use of a few buttons and one leddigits widgets. I have simulated all the widgets with the GTX tool and they are working fine. I am using RealTerm to further simulate my design, I am communicating at the default of 9600 baud and have not changed any other settings in Visi-Genie.

    The buttons are responding correctly and everything is good. However when I try to write to the leddigits to update them, nothing happens. I get no response from the display and nothing updates. The serial string I am sending is: 01 0F 00 00 64 6A. Which should tell the leddigits to update to a value of 100. This is the same string I saw in the GTX tool which works correctly. I have also used the terminal 9600 tool in workshop4 and sent the hex string and it works correctly.

    I am using the gen4-PA board pins RX0 and TX0 to interface with RealTerm. This is the default for COM0 in Visi-Genie according to what I have read. Can anyone assist me in figuring out why I can receive serial strings for button presses, but can't send serial strings to update leddigits? I have read that some people experience issues trying to use COM0 with a terminal program or microcontroller. Do I need to use COM1 and assign them to GPIO pins on the gen4-PA?

    Thank you in advance for the assistance.

  • #2
    Hi,

    Welcome to the forum.

    The serial string I am sending is: 01 0F 00 00 64 6A
    I don't really know much about RealTerm but based on this Article, hexadecimal values should be prefixed with a "0x" or "$".

    That being said, could you please try sending 0x01 0x0F 0x00 0x00 0x64 0x6A instead?

    I tried this on my end and it seems to have worked well.

    I hope this helps.

    Best regards,
    Michael

    Comment


    • #3
      Thank you for the response. I should have been more clear as that’s what I did. In the “send” tab on RealTern I I tried to send: “0x01 0x0F 0x00 0x00 0x64 0x6A” however this did not get a response of update the leddigits. Is there a setting with the widget in workshop4 or a con setting that I might not have enabled? Is there an alternative to RealTerm that you would suggest that isn’t part of the workshop4? I’m at a loss as to why RealTerm worked for you but not me. Could you detail your setup? Thanks again.

      Comment


      • #4
        Hi Micah,

        May I ask why you'd like to use realterm instead of the utilities provided with Workshop4?

        Since we're not maintaining realterm, we cannot assure you that it's doing what it claims to do.

        It's quite possible that realterm is doing other stuff behind the scenes that we do not know of.

        Nonetheless, here's my setup.

        I have a gen4-uLCD-24PT connected to my PC with a gen4-PA and a USB micro b cable

        I created a project with ViSi-Genie Containing a Led Digit and a slider.

        I didn't do anything on the events tab.

        I sent write object commands using the GTX. I copied the commands sent from GTX then closed GTX.

        I setup realterm with the following specifications:

        Under the Display tab I choose Hex [space] on the "Display as" section.

        Click image for larger version

Name:	display_rt.PNG
Views:	92
Size:	12.0 KB
ID:	68180

        Under the Port tab, I choose 9600 baud, the port where my device is connected, no parity, 8 data bits, 1 stop bit, no hardware flow control.

        Click image for larger version

Name:	port_rt.PNG
Views:	37
Size:	11.0 KB
ID:	68181

        I then went to the send tab and sent the prefixed version of the hex string that was sent from GTX.

        After clicking on 'Send Numbers', I get a '06' or acknowledgement response from the display.

        Click image for larger version

Name:	send_RT.PNG
Views:	31
Size:	14.4 KB
ID:	68182

        I hope this helps.

        Best regards,
        Michael

        Comment

        Working...
        X