Announcement

Collapse
No announcement yet.

MD1 flash memory

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MD1 flash memory

    Hi!

    I have built a simple monitoring system using Arduino which is serially connected to Picaso-MD1(with base board). Unfortunately Arduino only has 16KB of ROM, which makes it difficult for me to implement a bit more complex user interface(current one is pretty simple). I was wondering if Picaso-MD1 has any internal flash memory which could be used to store bitmap images. I'm aware of the uSD card option but as I understand it is yet to be implemented. Also is the uUSB-CE5 any use to me if I don't intend to update MD-1's firmware? Any suggestions would be greatly appreciated.

  • #2


    Any help would still be appreciated

    Comment


    • #3


      Hi,

      The Picaso-MD1 does support raw bitmap images, please see the reference here
      http://www.4dsystems.com.au/developers/index.php?cat=30#tblcontent
      and the corresponding examples in the project folder of the workshop.

      The uUSB-CE5 is useful only if you don't have any other means of communication with the device but also because it is known to work 'out of the box' with the device.
      Otherwise you can use any other serial communication method, the onl required line for firmware download is the 'reset' line.

      Regards,
      Julien

      Comment


      • #4


        Thank you for the reply. I still don't understand one thing. Is MD1 with baseboard supported by 4DGL? The way I see it, I can't store raw bitmaps to MD1 since uSD card is not yet implemented. That's why I was wondering if MD1 has any internal flash memory that could be used for storing bitmaps.

        Regards,
        Luke

        Comment


        • #5


          Oh I see what you mean, sorry you have to wait until a new firmware for the uVGA is released and supports FAT16 image control

          I've had limited success in adding bitmaps directly into the flash memory of the device, but it's possible:
          You have to extract the raw bytes of the picture using a program (GIMP does that IIRC) and then input it in the workshop using the byte or word directives.

          Beware that you have roughly 12KB total of flash which is not much to store bitmaps especially in code form.

          Good luck,
          Julien

          Comment


          • #6


            Julien wrote: Oh I see what you mean, sorry you have to wait until a new firmware for the uVGA is released and supports FAT16 image control
            Good luck,
            Julien
            4D folks,
            ETA on new firmware for the micro-VGA platform???
            I've a project waiting for it, but if I have to wait too much longer I'll be looking for another way...

            Comment


            • #7


              Hello, I need help(again ). Is it possible that there is something wrong with my MD1, since it crashes(random patterns appear) when I try to wait for ACK after I send it auto baud command. However it works, if I insert a delay(instead of waiting for ACK) after 0x55.

              I have also noticed that the following commands aren't working(the ones I have tried): Version/Device Info Request, vsync Lock, Display Page Select, Write Page Select. So far, only the basic draw commands are working(draw rectangle, circle, ellipse, text, pixel, ...). I have tried different baud rates(2400, 4800, 9600, 115200) and the result is always the same. One more thing I have found out is that, if I use 2400 baud rate and I send the 0x55 command two times successively without a delay and than waiting for ACK, it works. However, it doesn't work with other baud rates or other commands.

              I have managed to accidentally fry my previous MD1(the cable was attached the wrong way) and I have only replaced MD1 and not the baseboard. Could it be that I have also fried the baseboard and that it's causing the problems?

              I use the following code for initialization:
              HTML Code:
              Serial.begin(115200);
              delay(500);
              serialWrite(0x55);
              waitACK();
              
              void waitACK()
              {
              bool wait = true;
              while(wait)    {
              if(Serial.available() > 0)
              if(Serial.read() == 0x06)
              wait = false;    
              }
              }
              Connections to the host controller are as described in the manual. Perhaps a silly question, but shouldn't the voltage on MD1's Rx pin be lower after inserting 1kOhm resistor(mine is 4.76V)?

              I'm kind of reluctant to buy the uUSB-MB5, just to see if the MD1 is working, since I have spent too much money already. However if it's the only way...

              Thanks!

              Comment

              Working...
              X