Announcement

Collapse
No announcement yet.

GFX4D and IoD-24T compiler issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GFX4D and IoD-24T compiler issues

    Hi,

    I am here again. The compiler throw out error messages what I do not know what does it mean.
    Please help to understand what happens.

    Peter
    Attached Files

  • #2
    Hi Peter,

    It looks like some libraries for the ESP8266 core are missing. The IoD will use the SD library and the HTTP library and it looks like the are missing. It might be easiest to re-install the ESP8266 core again and it will replace these missing libraries. They are not stored in the Arduino Libraries folder, they are stored within the ESP8266 folder.

    I hope this helps

    Paul

    Comment


    • #3
      Hi Paul,

      The SD and the GFX4D on the right place. SD on the ESP folder in users and the GFX4D on the Arduino/Libraries folder where the IDE has installed even so it is not working.


      Peter

      Comment


      • #4
        Hi Paul,

        I have made fresh install both IDE, everything in the right places but the result is the same.

        I am not really understand this situation.

        Peter

        Comment


        • #5
          Hi Peter,

          I have done some tests and it is a problem with the ESP8266 core version 2.5.1 Can you please revert back to 2.5.0 while I make some changes to GFX4d to work with 2.5.1 You will have to do this in Boards Manager in the Arduino IDE

          Best regards

          Paul

          Comment


          • #6
            Hi Paul,

            The 2.5.0 version of ESP8266 could solved the before mentioned messages but the compiled time error still exist.

            After that I have had an idea. I deleted all library from the Arduino folder except what I am using and then the compiler has started to work.
            Just for check I copyed back the deleted libraries and interesting that the compiler still working.

            Honestly I am not understand how is it working or if it is not working then why not.

            Peter

            Comment


            • #7
              Hi Paul,

              Now the compiler not working again. This is what I try to tell you that. All of I did that I copied the new GFX4D files (more obejcts) to the GFX4D folder.

              Peter

              Comment


              • #8
                Hi Peter,

                I have attached another version of GFX4d that will work with Both 2.5.0 and 2.5.1 which will be fine until they fix the error in the core. I would advise that you re-install everything again. There is advantages to using 2.5.1 due to the use of SDfat being wrapped in a SD class as SDfat perorms a little better.

                Best regards

                Paul
                Attached Files

                Comment


                • #9
                  Hi Paul,

                  Unfortunatelly the Compile timed out arror message appeird again so I cannot check what you have done. I have no more ideas.

                  Peter
                  Attached Files

                  Comment


                  • #10
                    Hi Peter,

                    Ok not to worry, we will do this from the start again using the Arduino IDE and we can also extend the timeout in Workshop at the end but it is important to get the Arduino IDE right first

                    You can, if you want, re-install the Arduino IDE so we are starting from new.
                    Go to Boards manager in the Arduino IDE and install the ESP8266 core version 2.5.1

                    When that is done, download GFX4d from here https://github.com/4dsystems/GFX4d

                    Now, the preferred location for libraries is in your Sketchbook folder which is normally defaulted to your Documents\Arduino\Libraries folder unless you have set it up a different sketchbook location.

                    Once done, open your project in the Arduino IDE to make sure everything works in the IDE before you try Workshop

                    Best regards

                    Paul

                    Comment


                    • #11
                      Hi Paul,

                      Ok, I think the 4D Systems boards has a large number of very good and creative solutions what is 100% useful. Actually I love these displays and I have many-many ideas and projects what I want to bring to the reality but sometimes I have to put many working hours to keep working the IDE.
                      Sometimes the systems working weeks and then suddenly drop up an error what I cannot understand where comes from and why but I still beleive.

                      So, the core is up-to-date 2.5.1, the GFX4D is the lates and it is in the sketch book folder.

                      Firstly for just try with a very simple code, I have opened an ESP8266 example named BLINK from the Arduino IDE examples.

                      The result is the same what I have expected from few hours ago.

                      The message is the following:
                      In file included from C:\Users\Hanák Péter\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.1\cores\esp8266/Arduino.h:27:0,

                      from sketch\Blink.ino.cpp:1:

                      C:\Users\Hanák Péter\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.1/tools/sdk/libc/xtensa-lx106-elf/include/stdlib.h:16:20: fatal error: stddef.h: No such file or directory

                      #include <stddef.h>

                      ^

                      compilation terminated.


                      It seems this stddef.h missing somehow.
                      This is a very new phenomenon.

                      Peter

                      Comment


                      • #12
                        Hi Peter,

                        It isn't common to have issues with the IDE once it has been setup but unfortunately, the updated 2.5.1 core which had a compatibility issue with existing SD code, caused a new issue for you which forced us to work around it with an updated GFX4d, but these things happen.

                        The missing library is actually a core issue which I am testing now, that file should have been installed when the 2.5.1 was installed. GFX4d was modified to work with previous versions as well as the new one so it might be worth a try going back to 2.5.0 and then test Blink.ino to see what the result is.

                        Best regards

                        Paul

                        Comment


                        • #13
                          Hi Paul,

                          I have tested what you have asked for and the result was interesting.

                          I have started with a fresh Arduino IDE install. After that I installed the 2.5.1 version but the result was the same like before. The IDE has not found the stddef.h.
                          Nest step was roll back to 2.5.0 the result was the same.
                          The next version was a little bit different because the 2.4.2 downloaded more than 140Mbyte which is much more than the other.
                          Interesting that with this version the compiler run down properly.
                          When I saw it is ok then I installed back the 2.5.0 version and the stddef.h missing error message appeared again.

                          This time I used TouchTest4D instead Blink.

                          Peter

                          Comment


                          • #14
                            Hi Peter,

                            Yes this happened to me also. The different versions don't get downloaded again but are retrieved from this folder C:\Users\** Your Name **\AppData\Local\Arduino15\staging\packages. You could try removing all the files in this folder and then try 2.4.1 and then 2.5.1 This time after you have installed 2.4.1 select 2.5.1 and then press update instead of install, this worked fine for me.

                            Best regards

                            Paul

                            Comment


                            • #15
                              Hi Peter,

                              I have attached the registry key for the modified timeout, just extract it and then double click it and it will install into the registry for Workshop. You will then have to restart Workshop for the change to take effect.

                              Best regards

                              Paul
                              Attached Files

                              Comment

                              Working...
                              X