Announcement

Collapse
No announcement yet.

GFX4D and IoD-24T compiler issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hi Paul,

    Unfortunately this methode of installing different versions of ESP8266 is not working for me. The 2.4.1 is working fine. I started compile more then one time and it is ok but after 2.5.2 the stddef.h missing appeired agaein..
    May be I missunderstood your way of installing.
    What I did, I removed all files from from \staging\packages then I installed the 2.4.1 from the board manager and then I updated the 2.5.1 from the board manager as well.
    Is this what you mean?

    Peter

    Comment


    • #17
      Hi Peter,

      Yes that was the way I meant, I am at a loss as to why it doesn't work for you. I did a search for stddef.h in my Arduino15 folder and found 2 instances of stddef.h

      C:\Users\** Your Username **\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\2.5.0-3-20ed2b9\lib\gcc\xtensa-lx106-elf\4.8.2\include

      C:\Users\** Your Username **l\AppData\Local\Arduino15\packages\esp32\tools\xtensa-esp32-elf-gcc\1.22.0-80-g6c4433a-5.2.0\lib\gcc\xtensa-esp32-elf\5.2.0\include

      And also in the Arduino program folder

      C:\Program Files (x86)\Arduino\hardware\tools\avr\lib\gcc\avr\5.4.0\include

      Would you like to send me your project again as it is and I will try to compile it on my setup here to see if I can replicate what you are getting as an error.

      Best regards

      Paul

      Comment


      • #18
        Hi Paul!

        It is unbeleivable! It is working and I do not know why!

        Today morning I woke up, made my coffe, sat down before the PC and made a fresh install from Arduino as many times in the last few days just because.
        After that I started a compile in Arduni IDE and it worked.

        There are no difference between installations and do not know what happens. The Arduino IDE just thought one and started to work. I am just courious how long will it take.

        But as I see my library structure and your library structure a bit different. I attached a picture from my library structure.
        As you see in the ESP8266 library I have only one place what is contains the stddef.h and also the Arduino.

        Another info. After installing a fresh installation from Arduino I use standard GFX4D library and the compile time out came up.
        After that I started to use the GFX4D library what you sent to me before. With this library the compile time out gone.

        Ok, now it is working. I hope it wil be stable. :-)

        Peter Click image for larger version

Name:	library_structure_stddef.jpg
Views:	17
Size:	257.0 KB
ID:	68365

        Comment


        • #19
          Hi Peter,

          Thank you for the update, thats great news. Did you use the registry key for Workshop for the timeout change, just curious in case I have to make it longer.

          Lets hope there aren't any updates to the Arduino IDE or ESP8266 core for a while

          Best regards

          Paul

          Comment


          • #20
            Hi Paul,

            Yes I have to use the registry key but now it is working and the bonus is I do not have to press the reset and flash button to upload the code. Yessssss....!

            Big thanx for your cooperation and effort in my case.

            Peter

            Comment

            Working...
            X