Announcement

Collapse
No announcement yet.

Strange issues w/ GND

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange issues w/ GND

    Hi all,

    We have a gen4 ulcd 43dct clb, which we use as a user interface in our product. We used it in the past (2017), hw rev 1.2 and 1.3, and had no problems. However, we have 2019 screens now, hw rev 1.5, and they seem to not respond to received messages. We can solve this problem by "grounding" the device to a floating laptop via usb (shield cut, data lines cut, positive power cut), and then it will function like the hw rev 1.2 and 1.3 screens. However, removing the usb cable will reinstate the problem.
    The problem does not occur when I remove the cable ~500ms after applying power, suggesting a turn-on transient. There is a local SMPS module regulating 24V down to 5V. This was also present in the rev 1.2 and 1.3 devices.

    We tried grounding the screen using one of the large gnd pads, that didn't work. We have also tried adding various size capacitors on the power supply lines, that didn't work either.

    Any ideas how to solve the problems we are experiencing?
    Last edited by RamonS; 6th June 2019, 01:59 AM.

  • #2
    Hi Ramon,

    I sent you a Private Message with instructions on resolving this.

    Best regards,
    Michael

    Comment

    Working...
    X