Announcement

Collapse
No announcement yet.

Having to remove sdcard to copy files

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having to remove sdcard to copy files

    I didn't know that the card had to be removed when changes were made to copy files to it. The display will be installed behind the dash of my vehicle. There is no way to get to the card to remove it. Why have a programming cable if it won't do the programing? If I had known this I wouldn't have gotten it. Is there any way around this?

  • #2
    Hi,

    Welcome to the forum,

    It is possible to copy the files to the display without removing the SD card. We have a utility that will allow you to do this when the display is connected to the PC and allow you to copy the created GCI & DAT files that were created when you compiled your project.

    If you take a look at this forum post

    https://forum.4dsystems.com.au/node/62492

    You will find the download link and also some useful information on how to use it. The transfer is quite quick as it will attempt to upload to the displays SD card at the fastest baud rate.

    I hope this helps

    Best regards

    Paul

    Comment


    • #3
      Thanks, did not find that with search. Will try that. Was going to put in a extension cable but the part that plugs in the sd card slot is a little wide and would need to trim a little plastic to make fit. This should work better.

      Comment


      • #4
        The File transfer program works but on the high speed it has errors when connecting. Is there a way to get a speed in-between the 600000 and 2187500 speed. like 1000000 or 1500000?
        Im using all your hardware so I don't know why it has a problem.

        Comment


        • #5
          Sorry, no, each available speed is selected for come rather complex reasons.

          Also 2187500 is not 3 and a bit times faster than 600000, so the difference is not worth an 'extra speed'.

          So lets try and debug why you are having errors.

          Can you document exactly the type of programming device you have cable lengths and the like, perhaps a photo of your setup and a copy of the file transfer log showing the error
          Mark

          Comment


          • #6
            I'm using your hardware GEN4-ULCD-70DT-SB, 3D-UPA and FFC Cable. Multiple usb cables. Windows 10 desktop computer. I tried it on and old netbook windows 7 computer and it worked at max speed. The only difference was it would not install the usb bridge driver automaticly. I downloaded a driver and manually installed the driver. The driver was from silicon labs. And this works ok on the netbook. Also used all the same hardware so it should not be a hardware or cable problem.
            I tried to update the driver in the desktop to this one but it says the best driver is already loaded and wont let it be changed.

            Attached the log file

            Attached Files

            Comment


            • #7
              Can you check the driver version in Device Manager?

              The log you supplied is a bug report, which appears to be a 'File not Open' crash when FileTransfer tried to change the baud rate. This should not occur, well I guess it could if the driver were completely cactus.

              I really meant the log in the file transfer program (You'll need to take a screenshot).
              Mark

              Comment


              • #8

                Here's the drivers from both computers. the 2019 date is the desktop and the 2018 is the netbook

                Click image for larger version

Name:	desktop.png
Views:	23
Size:	138.6 KB
ID:	70178Click image for larger version

Name:	netbook.png
Views:	23
Size:	134.7 KB
ID:	70177
                I dont know what you mean log file transfer program. This is the screen when it happens and the earlier post was the log that it stores.

                Click image for larger version

Name:	transfer.png
Views:	22
Size:	265.0 KB
ID:	70179
                Attached Files

                Comment


                • #9
                  Ok, I figured I would try something while I waited. I removed the driver and deleted the files. Then I manually installed the driver I downloaded for the netbook even though it said it was for windows 7 and 8. Now it connects at the max speed. I will check tomorrow and make sure it transfers files at that speed ok.

                  I don't know why the one that automatically loaded doesn't work correctly but the older one seems to.

                  Comment


                  • #10
                    I just uploaded files to the display and it works fine now.
                    Don't know if you need to check anything but I'm great for now.
                    Thanks

                    Comment

                    Working...
                    X