Announcement

Collapse
No announcement yet.

Installing μUSB-MB5 driver for windows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing μUSB-MB5 driver for windows

    Hope this video helps people out. video here

  • #2


    Even after following this video I'm still having problems. It's not showing up as a COM port even when I plug the uUSB in. Also I tried restarting my PC and that didn't help. All I see are the COM ports attached to the computer. Any thoughts?

    Comment


    • #3


      Hopefully you installed the drivers without the uUSB plugged in, if not, try again.

      And yes, it only shows up when it is plugged in.

      If all the above are correct, what happens when you plug it in? Any windows notifications? And what about device manager, any devices with a yellow ? or a red x?

      Comment


      • #4


        Sorry, still no luck. I uninstalled the drivers and Silabs, restarted the PC, reinstalled everything (SiLabs & then Drivers), restarted, plugged in the USB and got no reaction. The device does get power through the USB, but no port is detected in the device manager and I don't get a windows notification. Also I don't see a yellow '?' or red x anywhere in the device manager.

        Comment


        • #5


          Hello,

          Re-install the windows driver for your device and once your done connect your microUSB or CE5 to your USB port. After that go to the device manager (make sure your device is connected to the USB port) and click on the + sign on the ports (COM & LPT) tab and it should show Silabs or driver or something like that. Depending on your computer your device COM port your device maybe be COM2 or COM6. Mines is COM Port 2. Just follow these steps, it took me awhile to get mines working too.

          I hope this helps!!!
          Bradley Gibson

          Comment


          • #6


            no that still doesn't seem to work. I also tried it on another computer that doesn't have any serial ports and after installing all the drivers and restarting, nothing showed up in the device manager when I plugged in the USB. Do you think it's a defective uUSB-MB5?

            Comment


            • #7


              There would appear to be a good possibility of it.

              If you plug it into a (Windows) PC without drivers windows should go through the 'Found new hardware' procedure all by itself without any prompting.

              Of course it could be the cable.

              Does a 'red' led come on on the MB5 when it is plugged in? (it should)

              Comment


              • #8


                Yes, the red LED does come on when plugged in. And if the uOLED-160-G1 is connected to the micro-USB, the screen turns on and shows the 4D splash screen animated graphic. I don't think it's the cable.

                Comment


                • #9


                  I'm really at a loss for why, but it's working now. I tried it on two other computers and it didn't work on the first, but it did work on the second. Then it started working on the original computer. I'm fairly confused, but I'm glad that's taken care of.

                  Comment

                  Working...
                  X