Announcement

Collapse
No announcement yet.

Arduino Gen4 -ULCD-43D

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Arduino Gen4 -ULCD-43D

    I am having a problem writing to the new 43D LCD. This was working ok with older 43d/Arduiono Uno (and Pro mini v), It now runs super slow (was cycling 3-4 times a second, now once every 4-5 sec). I have narrowed it down to the "genieWritexxx" commands. Any genieWrite command significantly slows down the run loop. Is there a different syntax or library for the Gen4 lcds?

    I have attached code listing

    thanks for any help offered

    tom
    Attached Files

  • #2
    Hello Tom,

    There's no specific library for gen4 display modules, and there are no known issue/s like you have mentioned.

    If it is alright, could you please post video/s of this case?

    Thanks and best regards,
    Sherwin

    Comment


    • #3
      Sherwin

      Sorry about the delay responding.....

      I believe that I found the problem. I apparently "added" a short to the LCD TX line (when soldering the Flex connector to my interface pcb). I suspect that after a while, the internal firmware was generating internal error codes that slowed down the Diablo uP. Removing short fixed everything or so I hope.... It was frustrating that first thing in the morning, it would power up ok, then fail after 5 minutes of running.

      Appreciate your being there.....

      Comment


      • sherwin4D
        sherwin4D commented
        Editing a comment
        That's great to hear. Glad you have it sorted out.

        BR,
        Sherwin
    Working...
    X