No announcement yet.

Using large >4G uSD cards, formatting and partitioning

  • Filter
  • Time
  • Show
Clear All
new posts

  • Using large >4G uSD cards, formatting and partitioning

    I have a copy of your "General Partitioning a micro-SD into FAT and RAW Components" dated April 2019. It does not even mention larger uSD cards. Do you have a tutorial on using larger (8, 16, & 32G) uSD cards and how to set up?

  • #2

    Using latest version of Workshop 4D IDE on PC w/ WinXP SP3

    Using RMPet, I can re partition SD, but am prompted to remove/replace. WinXP does not recognize SD card after reinserting.... XP only allows FAT32 formatting.....


    • #3

      Could you please provide more information regarding your setup? It is possible to transfer compiled graphics from PC to display module without using uSD card reader.

      Please see this thread for your reference:
      File Transfer over serial (Programming) cable Utility



      • #4
        Not sure I understand your request.....

        Using default install of Workshop, designed graphics, trying to install on SD. I have 16G SD cards, I am having a difficult time reformatting them in FAT16/4G blocks. WinXP will not allow it, RMPet will delete FAT32 partitions, but then when I remove/reinstall SD per instructions, WinXP does not see SD. I have copy of BOOTice, but still have some problems w/ SD formating...

        Will a 16G SD work in Gen4 LCD with the serial mode you reference?

        This setup worked great when I had 2G/4G SD's, now no longer locally available...


        • #5
          Apologies if I wasn't clear enough on my reasoning/s behind my request.

          My understanding of the current situation you're in is that, you have already formatted the uSD card with RMPet - which I surmise, is the reason why WinXP doesn't recognize it afer that procedure. And so, I recommended that you use the File Transfer tool to transfer the graphics files from PC to display module. Could you please try to verify this? In addition to that, please provide screenshots on how you are trying to format the uSD card.

          After partitioning the SD card, please try to format using Windows:
          Choose StartControl PanelAdministrative ToolsComputer Management. In the resulting Computer Management window, double-click Disk Management in the list at the left side.

          It is also possible that the main culprit here is the uSD card itself. Could you please give us more information on the uSD card used? It is worth noting that Not All uSD cards support SPI:

          You can find our recommended uSD card here:
          4GB Industrial Grade microSD Card

          I hope this information helps.

          Thanks and kind regards,
          Last edited by sherwin4D; 30 April 2020, 04:24 PM.


          • #6
            I am having difficulties formatting large (16G) SD cards with RMPet. Since I am running WinXP, the moment I delete partitions, I amd prompted to remove/reinstall SD due to XP "bug". When I do this, XP no longer sees SD and I can no longer access it. I have tried third party formatting tools, but am having dificulties getting the right settings that work.

            Since I am not able to find 4G or smaller SDs locally, do you (4D) have a procedure for using larger SD cards? Do the displays work with larger SDs?

            I am using both Vebatim and Kingston 16 G SDs. I have been assured by both that they are SPI compatible.

            WinXP does not support Fat16 formatting as far as I am able to determine

            I will try the file transfer method when I can....


            • #7
              I just did a test, have a little XP machine running XP SP3, installed WS4 on it and ran RMPET, put a SD card in the media slot which was originally FAT32 formatted, it detected it, I deleted the partition on it, up came the prompt with the XP bug, so I clicked OK, removed the card, put it back in again, refreshed the Drive, then I created a new FAT partition (FAT = FAT16), prompt came up again, clicked OK, removed the card, put it back in again. Refreshed the drive again, then clicked format, and it formatted it correctly to FAT (FAT16). No issues.
              That was a 4GB card.
              I then tried a 8GB card, and that also worked fine. 4GB FAT16 partition, the rest is RAW.

              Click image for larger version  Name:	20200501_091926 (Large).jpg Views:	1 Size:	928.1 KB ID:	71953

              Click image for larger version  Name:	20200501_091716 (Large).jpg Views:	1 Size:	852.0 KB ID:	71954

              Click image for larger version  Name:	20200501_092555 (Large).jpg Views:	1 Size:	825.6 KB ID:	71955

              Can I ask though - why are you using a PC running XP in this day and age. XP has not been supported my MS for years...
              If your computer is not recognising the card after you delete the partition, then potentially there is something weird with your card reader or something - I cant really help with that I am sorry. But as above, the process does work on my little XP machine I have.