No announcement yet.

white screen on uLCD-43DCT-CLB

  • Filter
  • Time
  • Show
Clear All
new posts

  • white screen on uLCD-43DCT-CLB

    I received a uLCD-43DCT-CLB today and I am a new 4D user. (I am an experienced embedded systems programmer, fwiw .
    The display started up correctly at first. I followed the instructions in the Getting Started manual. I had no problem communicating with the device, formatting an SD card, and building a first simple project. I got as far as seeing the slider on the display, but the cool gauge didn't show up.
    I figured maybe the graphics for the gauge were not loading from the SD card properly, who knows, in any case I was eager to learn, so I started exploring tools in the workshop.
    Unfortunately my curiousity seems to have killed the cat, that is to say I must have done something wrong at some point...because now the display has gone full white at power-up, no matter what I do.
    I have tried reloading the default serial mode project, I have tried automatic and manual reloading of the driver and PmmC.
    The problem may have started when I first tried an automatic PmmC update. Or maybe it was a mistake to click on the "Update Banks and Run" button?

    The PmmC loader at this point reports:
    Current PmmC 'Diablo 16' version '20'
    Current Driver 'Gen4-uLCD-43DCT-CLB-A' dated '16-06-09'

    Any suggestions on getting back to something beside a nice bright white blank screen? Thanks in advance!

    kind regards,

  • #2
    Some additional information on the issues I am experiencing:
    I moved on to trying the other display I received today, a GEN4-uLCD-24D-CLB.
    I experienced odd behavior with this device as well, for example an lcdDigits object would load, but always at 0,0 position. I could read and write it's value with the gtx tool but the display would always show 00.00.
    This prompted me to try a different host computer. My original tests were done on a VM (Parallels running Win 7 on macOS), so I moved to a new machine running Windows 10.
    The uLCD-24D is now working just fine. I have tried a number of tests, all good!
    Unfortunately, the 43DCT-CLB is still displaying all white. I can communicate with the Diablo16 processor, tried a bunch of commands after reloading the SPE program and the ACK's and data returned seems to make sense. But I can't see anything but white pixels, so it's not exactly functioning as an HMI, haha!
    I have a project deadline to build a product prototype using this model, any assistance would be greatly appreciated.