Announcement

Collapse
No announcement yet.

Address Trap Message at boot

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Address Trap Message at boot

    I'm working with a uLCD-24D and created some project with Visi Genie and worked ok.
    Yesterday I upgraded the Workshop framework and tried to create a new project.
    Copied the files to the card and connected the module with a serial cable as before.
    At startup and after the flashing phase I got
    ADDRESS TRAP
    My project includes 2 forms, the first one just an image.
    I compiled and loaded the old project but the problem remains.
    The comm tab identifies the module but aditional action with the comm port reports that is not available
    I don't know what is the problem

    Attached Files

  • #2
    From the picture it appears you are using the old 2.0 PmmC, didn't Workshop prompt you to update the PmmC?

    Also, you appear to be using the New Internal Led Digits. These require the new PmmC.

    So, are you saying you had the Internal Led Digits in a previous project? If so, you must have been given access to one of the internal Workshop releases where Internal Led digits worked in a completely different manner to the way it does now.

    Regardless, updating the PmmC should solve your issue.
    Mark

    Comment


    • #3
      Thanks for you comments.
      I created another project with simple objects and it loads and I can control it with GTX.
      Unfortunately I can't get the PmmC update.
      Although I can send command via serial port (GTX) any additional option that involves the serial port doesn't seems to work.
      That includes the PmmC Loader execution automatic ou manual mode.
      Every time I got the error "Device on COM4 is not responding".
      Is there a way to upgrade the PmmC by other means?

      Attached Files

      Comment


      • #4
        Hi,

        It looks like your com port is in use by another program while you are trying to use PmmC Loader

        Could you please check that the com port isn't being used by another program. If GTX is being used before hand, please close it and try again.

        Best regards

        Paul

        Comment


        • #5
          Thanks for your note.
          I was using a FTDI cable and probably this is the problem.
          Now I tried with the programming cable and seems working ok

          Comment

          Working...
          X