No announcement yet.

Screen rotation on GEN4-4DPI-50T

  • Filter
  • Time
  • Show
Clear All
new posts

  • Screen rotation on GEN4-4DPI-50T

    Hi I've just set up a GEN4-4DPI-50T screen and it all seems to be working fine, however I'm having some trouble getting the screen to rotate.

    I've followed the instructions from the quick-start guide as well as the suggestions on the two previous similar posts on the issue that I could find on the forums, but to no avail:

    I was hoping there was something else I could try to sort this out.


  • #2

    The instructions in the datasheet on how to rotate the display should still work even with the latest image.
    You should just need to access cmdline.txt and add 4dpi.rotate=90 or other rotation value, and then save and reboot. It then should work.

    I have looked at both of those posts again, and that is what I would still suggest you do...

    So its still not working?
    Maybe can you provide your cmdline.txt file?



    • #3
      Good day!

      Just as mentioned, the instructions should still work with the latest image. But here are some additional comments that might be helpful.

      Are you using the latest Raspberry Pi OS? If you do, you might want to consider building the 4DPi software package from source. This will provide best compatibility. If you already did this and still having the same issue, please let us know.

      If you are fine with using older Raspberry / Raspbian OS, it is best to ensure that both the OS and the 4DPi package has the same kernel version. You can check the kernel version of Raspberry Pi OS in their release notes as shown below:

      Currently, the latest build we have is for 4.19.97. The matching OS can be downloaded from here.

      Here are the other matching combinations:I hope this helps.

      Best Regards,
      Juniel Cruz


      • #4
        Hi James, Juniel,

        Thanks for replying. I've played around a little bit more, unfortunately with no luck.

        I've installed the Raspberry Pi OS from the image raspian-2020-02-07 (the first of three in your list above Juniel) coupled with the kernel version 4.19.97 as downloaded from this address:

        I've made sure not to update the OS either as I wasn't sure about any compatibility issues.

        My /boot/cmdline.txt file reads:

        console=serial0,115200 4dpi.rotate=90 console=tty1 root=PARTUUID=266982c5-02 rootfstype=ext4 elevator=deadline rootwait quiet splash plymouth.ignore-serial-consoles
        I've also tried moving the 4dpi.rotate term around to a few different locations in the file as well as trying different rotation angles all to no avail. The last thing to mention is that I've also checked the /sys/module/4d_hats/parameters/rotate file as per the other thread ( ) and it always reads as 180 no matter what I save as the 4dpi.rotate parameter.

        Thanks for any help you can offer.



        • #5
          Hi Gav,

          In case you didn't notice, I mentioned this:
          Currently, the latest build we have is for 4.19.97. The matching OS can be downloaded from here.
          You can see a different Raspbian OS version from the hyperlink. I believed this was released just a week after 2020-02-07 release which is the first item from the list of other matching combinations.

          I'm wondering if you have tested this as well. If you've tried it already and still having this issue, I'll try to replicate your issue with the latest matching pair and update you once I've confirmed the issue and found a solution

          Best Regards,
          Juniel Cruz


          • #6
            One more thing to check

            If the module is listed as /sys/module/4d_hats/parameters/rotate, then try to put 4d_hats.rotate=90 into cmdline.txt, instead of 4dpi.rotate=90.

            The module names should match I believe.

            Please let me know how you get on with this


            • #7
              Hi Juniel, James,

              I've only recently had the time to trial your suggestion and it seems as though it did the trick.

              For the record I used the 4.19.97 with the matching OS as suggested. I thought that I had tried this before, but perhaps I was mistaken.

              At any rate, thanks so much for your help.



              • #8
                I was facing the same problem using RaspiOS 2020-08-20 with 4DPi kernel release 5.4.68 and James' workaround solved it. Thanks a lot!