No announcement yet.

[4D-UPA] FileTransfer failed, run stand alone and check produced.....

  • Filter
  • Time
  • Show
Clear All
new posts

  • ESPsupport
    File transfer, run stand alone will default to the highest com port it finds. When run 'by' Workshop it will use the com port set in Workshop.

    I'm a bit confused about where the 115200, 600000 is coming from. I'm taking about the maximum baud rate used by file transfer, not the baud rate for the genie project and set in the project.

    The file transfer baud rate options are 'only' 115200 and 'max possible' and are found in options, Environment, 'FileTransfer Max Buad Rate'.

    I really think it is your driver, go into Device Manager, Ports (COM & LPT) and double click on COM4 and then 'Driver' and check the version.

    You should be able to force it by using 'Update Driver', 'Browse my computer...' and point it to the driver you downloaded. Hopefully it wont say 'a better driver' this way.

    Leave a comment:

  • faisal
    yes, workshop is set to com4, i don't know why but when I open File transfer it has the drop down set to COM6 and I have to change it. That's not an issue though.

    I always ensure the baud rate in workshop is set to the baud rate in file transfer. The maximum rate file transfer allows me to set is 600000.
    The image doesn't output at 115200 but it works at 600 000! I'm glad I'm getting an output at least! The flash erase helped. thanks!

    It's still a mystery why I need to set a baud rate of 600 000 and do a manual file transfer while a colleague of mine is able to run using the compile/load button with a baud rate of 9000.
    Do you think it's my driver? I tried to update my driver with your link but windows isn't letting me update because it has "a better driver already installed"

    Leave a comment:

  • ESPsupport
    So that looked like it worked, so all you would need to 'add' is the flash erase before the transfer and you you should be up and running.

    I note a couple of things, Filetransfer started with COM6 and you changed to COM4, I presume Workshop is set to COM4?

    The transfer was done at 115200, rather than the max 2MBaud. Whilst you can change the max speed in Workshop, I presume you have left it at 2Mbaud. What happens here if you use 2MBaud?

    Check the SILABs driver in use. There are bugs in the 10.x driver that stop it from working at high baud rates. If you have a 10.x driver 'delete' it and use the one we now have on our web site.

    Leave a comment:

  • faisal
    Hello Mark

    I appreciate your response. Here are 5 images showing my full process and results.
    1. upload my image
    2. compile
    3. manual file transfer
    4. GCF to display
    5. No output onto screen

    This is really odd because I've never had this problem with your other screens.
    I'm also able to upload SOME of your other widgets and they work fine. This image and some other widgets just don't work.

    This has been pulling my hair, I'd love to be able to discuss this over phone/vid if that's an option.

    Leave a comment:

  • ESPsupport
    So, if you do as the message suggests and run the file transfer utility by itself (it's in the tools menu) what messages does it give you?

    Leave a comment:

  • faisal

    any update on this? I'm having the same exact issue. I can run some widgets on my pixxi LCD 13P2 CTP but the minute I upload my own image and upload the code I get this error.
    I don't understand because how was the file transfer able to happen with the other widgets then?

    Leave a comment:

  • pauleilio

    Welcome to the forum

    Unfortunately the images you attached in the 2nd post are not available. Could you please try again.

    Best regards


    Leave a comment:

  • osh
    Click image for larger version

Name:	4d1.JPG
Views:	133
Size:	17.9 KB
ID:	73420

    Click image for larger version

Name:	4d4.JPG
Views:	118
Size:	14.0 KB
ID:	73421

    Click image for larger version

Name:	4d2.JPG
Views:	131
Size:	60.6 KB
ID:	73422

    Click image for larger version

Name:	4d3.JPG
Views:	130
Size:	51.6 KB
ID:	73423

    sample visi-gini code

    Filetransfer failed screen

    Last edited by osh; 1 September 2020, 11:28 AM.

    Leave a comment:

  • [4D-UPA] FileTransfer failed, run stand alone and check produced.....

    I am developing an HMI module using GEN4 and 4D-UPA.
    However, file transfer does not work when using VISI-GINE as Max Possible.
    So, another problem occurred when the communication speed was lowered to 115200.
    The file has been transferred, but the LCD screen component is missing.