Announcement

Collapse
No announcement yet.

Updated to pmmc 24 and genie.WriteObject(GENIE_OBJ_FORM stopped working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Updated to pmmc 24 and genie.WriteObject(GENIE_OBJ_FORM stopped working

    I am working with a Gen4-uLCD CD-35DT on a project that I've been working on for some time. Everything was working perfectly until I updated the LCD from PmmC 20 to PmmC 24, the Genie Arduino library from 1.45 to 1.51 and Workshop to 4.6.0.38 as I wanted to have a look at the new "Internal" functions.

    I updated Workshop first, then did the PmmC update. It went as expected, with no errors and everything was still working afterwards.

    Then I updated the Genie Arduino library to v1.51

    After the above updates I recompiled both the Visi-Genie project and the Arduino project and the genie.WriteObject(GENIE_OBJ_FORM,0x00,0) function stopped working properly. It's making the form change, but the function is never returning, locking up the Arduino.

    I have tried:
    • Reverting to the 1.45 Arduino library, this had no effect.
    • Reverting to PccM 20 (which is what the board had previously). This appeared to install and I reloaded the project, but afterwards all I could get out of the LCD was a TRAP error on screen. (Going back to PmmC 24 fixed that). I do not have 21, 22 or 23.
    • Making a new project and a new Arduino program that did nothing but try and change forms. It shows the same issue.
    • Testing the form switch using GTX, everything works as expected.

    I have not tried to backlevel Workshop, as I am not sure how that would go with my Pro license.
    I do not have a another LCD to try, nor can I afford to purchase one at this time.
    Other functions (such as SetContrast) are working without issue, it does not appear to be an issue with communications.

    Has anyone else seen issues with changing forms via code like this? A project I've been working on for a year is now at a standstill due to this.

    -Keith

    Note:
    Gen4-uLCD CD-35DT
    Arduino 1.8.13 under Windows 10 Pro.
    Visi-Genie project in Workshop Pro version 4.6.0.38

  • #2
    I've traced the problem to the latest versions of the Adafruit SAMD board library. (The Arduino in my project is an Adafruit ItsyBitsy M0 Express). It looks like any version 1.6.0 and up causes this issue. I must have updated my board libraries since I had last worked on this project. Backing down to 1.5.14 (the last of the 1.5.x line) removed the problem. I found the issue using another machine that, while it had the new version of Workshop (not pro) still had an older SAMD library.

    I am still curious if it's a combo of issues though. i.e. Is it only if you have the latest Workshop AND the latest SAMD lib? or the latest PccM and the latest LIibrary Since I can't seem to revert the PccM level, I can't test that aspect. If I find myself with a large amount of spare time I might try to backlevel the non-Pro Workshop machine and see if the 1.6.x libraries work with it.

    -K

    Comment

    Working...
    X