No announcement yet.

GEN4-4DPI-50CT-CLB Touchscreen only registers inputs in the top left corner

  • Filter
  • Time
  • Show
Clear All
new posts

  • GEN4-4DPI-50CT-CLB Touchscreen only registers inputs in the top left corner


    I am having trouble getting the touch screen working correctly. I’m using a Raspberry Pi model 3B+ running a fresh install of 2020-05-27-raspios-buster-armhf. It shipped with the Kernel version 4.19.1xx so I downgraded to 4.19.97 using the rpi-update command. No issues there and uname -r shows “4.19.97-v7+”. I followed the manual to install the kernel package for this exact kernel version from your website and didn't run into any errors either.

    I then plugged the display in and the screen itself works fine, the touch screen, however, does not. It registers inputs and movement, but the mouse cursor seems to be limited to a small area in the top left corner of the screen. I can't even use the calibration tool because it will only register clicks and movement in the very top left corner which confuses the tool. I checked the cable connection and it looks fine.

    Attached, you can find a video of the mouse cursor trapped in the top left corner as well as pictures of my cable connection. I don't think it's a hardware issue because I tried with two Pi’s and two displays and I am having the same issue with both.

    Click image for larger version  Name:	IMG_3332.JPG Views:	0 Size:	941.1 KB ID:	74619 Click image for larger version  Name:	IMG_3333.JPG Views:	0 Size:	983.9 KB ID:	74620

    I even tried using the newest Raspios release (2020-12-02-raspios-buster-armhf) but I couldn't test the it there because I got error messages during the installation of the kernel package. You can find the log file attached, but I don't think these issues are related.

    Any help would be greatly appreciated!

    Best regards
    Last edited by felix11; 23 December 2020, 11:51 PM.

  • #2
    Good day!

    When using a 4DPi, it is best to select latest matching kernel versions. Currently, the latest 4DPi kernel release has kernel version 5.4.68. You can find this under the downloads section of the product page. The Raspberry Pi OS release which is best suited for this kernel package was released on 2020-08-20.

    If you've tried using this configuration and you are still having this issue. Please submit a support ticket here and add a link to this forum thread in your discussion.

    Best Regards
    Juniel Cruz


    • #3
      Thanks for your reply. I tried using RaspiOS 2020-08-20 with 4Dpi kernel release 5.4.68 as you suggested and now the touchscreen is working fine

      Maybe you could add the information what RaspiOS image your 4Dpi kernel release is based on to the downloads section. This would have saved me some time because I tried using 4Dpi release 5.4.68 with RaspiOS image 2020-12-02 and this did not work.

      Best regards


      • Juniel Cruz
        Juniel Cruz commented
        Editing a comment
        Thanks for the suggestion.

        The kernel version package version corresponds to the Raspbian Kernel used to compile the drivers. Therefore, you can see the matching OS by checking the Raspberry Pi OS release notes.

        To find the right release, you need to use the OS with same or closest (lower) kernel version than the 4DPi kernel package.

        Best Regards