Announcement

Collapse
No announcement yet.

Open error on COMx. System cannot find file

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Open error on COMx. System cannot find file

    I have a new Gen4-uLCD-50DT-AR and want to load the Inherent Widgets into Bank 5 but I got the message "Open error on COM3. System cannot find file". But the display is connected to COM7.
    How can I change COM3 to COM7.
    This is my second Gen4-uLCD-50DT-AR and didnt had this problem.

    Thanks Frank.

  • #2
    Good day!

    To change your Com port in your Workshop 4, go to File --> Comms.
    As you can see my port here is Red which means it is not connected. Please refer to the picture below:

    Click image for larger version

Name:	Screenshot 2020-12-15 111046.png
Views:	14
Size:	13.2 KB
ID:	74673


    When it turns blue, it means it is connected. Please refer to the picture below:

    Click image for larger version

Name:	Screenshot 2021-01-08 092847.png
Views:	14
Size:	11.2 KB
ID:	74674

    Hope this helps,

    Best regards
    Attached Files

    Comment


    • Fvandeun
      Fvandeun commented
      Editing a comment
      Hi Sep,
      My comport for the communication with the screen is COM7 and that works fine but only if I want to load the Inherent Widgets into Bank 5 I got the message.
      My first setup was to use a 4.2" screen but later I switched to a 5.0".
      What I do now is:
      - I first open my 4.2" program (only open it in the workshop software with out download it to the screen)
      - then load the Inherent Widgets into Bank 5
      - close the 4.2" program
      - open the 5.0" program and downlowd this to the screen and now it is working.

      It works like this but I like to do it just by opening the 5.0" program because we are now busy with the testing the application and if this is correct we gone install about 30 5.0"screens.

      Thanks,
      Frank.

  • #3
    Hi Frank,

    It is strange that loading inherent widgets seems to only work when opening the 4.2" project. Keep in mind you only need to upload the inherent widgets to the flash storage of each display once, so perhaps your method might be the quickest solution for now.

    That being said, to find the source of this issue, would you be able to start a new 5.0" screen project and see if loading the inherent works?

    Regards,
    Adem

    Comment


    • Fvandeun
      Fvandeun commented
      Editing a comment
      Hi Adem,

      Thanks for the information.
      Next time when I start a new system with a brand new 5.0" display I will first download the inherent widgets before I download the project and see if this works.
      This can take a while because we are now starting to test the first system and this takes time.

      Thanks.
      Frank.
Working...
X