Announcement

Collapse
No announcement yet.

Error 30 / Impossible to load Inherents into bank 5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error 30 / Impossible to load Inherents into bank 5

    Hello,

    I am having some issues with my brand new gen4-uLCD-24DT-AR touchscreen :

    I made a new Visi Genie HMI and if I put any inherent widget in it, the screen displays "Error 30". I found that I should use the tool named "Load Inherents into Bank 5" but everytime I click on it, the following message appears : "Open error on COM/f Le chemin d'accès spécifié est introuvable"

    This only appears if I use inherent widget, otherwise, I have no trouble at all. All comms are good, I'm using a 4D-UPA adapter with drivers installed.

    Do you guys have an idea about what to do ?

    Thank you in advance,

    Seiffers


  • #2
    Hello Seiffers,

    "Open error on COM/f Le chemin d'accès spécifié est introuvable" -> "Open error on COM / f The specified path could not be found" - I assume you have the correct COM port selected and that COM port is not being used by any other application, and the UPA is directly connected from your PC to just the display module, right?
    Because you are using the -AR kit, I assume you have not got your gen4-uLCD-24DT display connected to your Arduino, and you are trying to program it via the Arduino or anything like that?
    The 4D-UPA needs to be directly connected to the display via the 30pin FFC cable only, no Arduino in the circuit.

    The message says COM not COM5 or COM4 etc, which suggests something is not right there.

    Please check and report back.

    Regards
    James

    Comment


    • #3
      Hi,

      My screen is directly connected to my PC using port 5 and the connexion seems all good : blue led under the COM port and screen PN as well as µSD card recognized.
      Click image for larger version

Name:	Capture_workshop.PNG
Views:	52
Size:	6.3 KB
ID:	74982



      Nothing else is connected. No arduino used. I tried with another PC : same issue.

      Best regards,

      Seiffers

      Comment


      • James_4DSystems
        James_4DSystems commented
        Editing a comment
        Your uSD is showing as 58,59 GB...
        Do you really have a uSD card this large inserted in your display module??

    • #4
      Hi Seiffers,

      Can you try updating the Silicon Labs driver you have on your machine, to be the latest one.

      Plug your 4D-UPA into your computer, go into device manager, under Ports (COM & LPT) and right click on the Silicon Labs device you have there, and right click and Uninstall Device. It will pop up a box for confirmation, and tick the box which deletes the driver software from your computer.
      Then unplug your 4D-UPA from your computer, and install the latest driver. Then plug the 4D-UPA in again once complete and you should have a clean install of the latest driver.
      See if that helps.

      https://www.silabs.com/documents/pub...ows_Driver.zip

      Regards
      James

      Comment


      • #5
        Hi James,

        Thanks for your answer. Unluckily, it does not change anything.

        Best regards,

        Seiffers

        Comment


        • #6
          This is so odd, lets try and do the 'load inherents into bank 5' process a bit more manually.

          Start the program loader utility.
          Set the com port
          Set the program to load as C:\Program Files (x86)\4D Labs\4D Workshop 4 IDE\INCLUDE\gfx_DiabloBankInherents.4FN
          Set destination to Flash
          Click OK and see what errors are produced.
          Mark

          Comment


          • #7
            Hi Mark,

            No error at all, it worked perfectly fine and I can use inherent widget now. Do I need to do this every time ?

            Seiffers

            Comment


            • #8
              You only need to do it once for each display you want to use inherent widgets on.

              Very confusing as to why this happens, I'll look some more though
              Mark

              Comment


              • #9
                Ahh, I see it now.

                The -AR model designation is for 'Arduino graphics'.

                If you are using Genie, or any other non 'Arduino Graphics' environment you should use the non -AR model.

                When you use the -AR model it uses the Arduino com port, which doesn't even display when using Genie.
                Mark

                Comment

                Working...
                X