Announcement

Collapse
No announcement yet.

leddigits will not compile

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • leddigits will not compile

    A few days ago I upgraded to your latest ide as I was having problems with user buttons - possibly too many and other strange behavior but no problems with leddigits.
    However now with the new 4d ide visi when I add leddigits it will not compile "leddigitsdisplay was not declared in this scope".
    Example file for leddigits compiles fine.
    So I start a new project and just add one leddigits wont compile in either 4d or arduino. New and not proficient in C but notice their is no # include leddigitcommand .
    As I said I have used leddigits before with no issues but now feel lost.
    Mike

  • #2
    Hi Mike,

    Thank you for using our product.

    You noticed it right, the LedDigitsDisplay library must be included in the code to declare the LedDigitsDisplay() function.

    Below is the snippet of the code that you need.

    Click image for larger version  Name:	snippet1.png Views:	1 Size:	2.3 KB ID:	75137

    You can also check the sample project attached with this comment that uses LedDigits and it worked fine for me.

    I hope this helps.

    Best regards
    Last edited by ivan_4d; 5 March 2021, 10:34 AM.

    Comment


    • #3
      Ivan,
      Thank you for the reply.
      Wish it was a day sooner though as yesterday I switched back to version 4.6.0.21 .
      I think the problems I was having with it (4.6.0.21) before came down to lack of loop logic. Still seeing the world in basic.
      Thanks again, Mike

      Comment


      • #4
        Hi Mike,

        We're happy to help!

        If you have other inquiries, feel free to open a ticket here 4D Systems helpdesk or a new forum post.

        Have a great day!

        Best regards

        Comment

        Working...
        X