No announcement yet.

Getting a 4DPi-32 to work with Octoprint

  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting a 4DPi-32 to work with Octoprint

    I have been trying to get a v1.3 4DPi-32 cape/hat to work with a RPi 3 model B and I just can't get anything to show on screen. I'm using Octoprint v1.5.3 image which i believe is based on Buster. It is my own image with all the files, mods and calibrations i use to print with so a clean install is not optimal. Here's what i've done so far:
    • tried installing the latest 4DPi-32 II kernel from the latest datasheet (4d-hats_4-19-97_v1.1 which matches my octopi kernel) and followed the instructions up until calibration and nothing showed on screen neither with changing the config.txt or leaving it alone
    • reimaged and installed the original 4DPi-32 I kernel recommended in other forum posts for a similar setup (gen4-hats_4-14-34_v1.1) then did the steps to change the config.txt
    • updated my image to 5.4.68 and then installed the same display kernel. nothing. then changed the config file for the dtoverlay=4dpi-32 and still nothing
    struggling with what i should do to get it working. all the instructions say it should just work after this. is it something to do with the octoprint instal? It doesn't have a desktop environment, but i would expect the terminal that it does load to to show up. Is there some other setting i need to change? maybe in raspi-config? please help
    Last edited by tsd; 8 April 2021, 12:36 PM.

  • #2
    also tried a fresh install of Octopi (5.4.79 kernel) then attempted to install the 5.4.68 kernel. It ended in the following message: "tar: Exiting with failure status due to previous errors" and then pi pi was unasable after that. i couldn't even type in commands like sudo reboot.


    • #3
      Good day!

      As you might already know, 4DPi kernel packages are built with Raspbian/Raspberry Pi OS in mind. That being the case, custom OSes that are based on the official releases may or may not work.

      The best thing for you to do is to use the following combination:After getting this to work, you can install Octopi on top this OS.

      I hope this helps.

      Best Regards
      Juniel Cruz