No announcement yet.

Smart Widgets - Custom Font

  • Filter
  • Time
  • Show
Clear All
new posts

  • Smart Widgets - Custom Font


    I realize this is an older post and the issue has been resolved. However I would like to know how the user was able to get the custom font in the smart gauge? I believe the font he is using is "DJB Get Digital"

  • #2

    You can select a custom font for the numeric part of a smart gauge. Please see the screenshot below.

    Click image for larger version

Name:	SmartWidgetEditor_Font.png
Views:	90
Size:	123.6 KB
ID:	75932

    Best Regards.


    • #3
      Thank you for your response but I am aware of how to change the font on the numeric part of a smart gauge. My question was how to add the custom font to the choice list? For example, the "DJB GetDigital" font is not available by default. How do I use it in my project for the numeric part of a smart gauge?


      • #4
        Its a windows font, so you just find the font on the internet and install it like any normal windows font, and then start Worskhop4 and it should pick it up.
        The font has nothing to do with WS4 as such, WS4 is just reading the fonts available on your computer, so if you don't have the font installed then you need to install it, and then start WS4.


        • #5
          Ah I see. I had read too deep into some of the app notes and thought the process was much more complicated than that so I didn't even bother doing a normal windows font install. Thank you for the help!

          I have another question related to this topic.

          I am using the smart gauge to try to create a numeric that will automatically change color based on the value. I realize I can do this by having objects of different colors on top of each other but using the smart gauge tool seemed more elegant and easier to interact with my host. I want transparent digits and don't want to use the custom digits object.

          Essentially I have a value between 0.0 and 10.0 with one decimal place.
          • 0.0 I want to be green.
          • 0.1 - 9.9 I want to be white
          • 10.0 I want to be red
          Using the numeric on layer 1 with the format 0.0 and min/max Values of 0/100 works great! The problem comes when I try to add a different colored numeric on layer 2. My attempt was to use the string lookup and have 0.0 at the top, followed by 99 empty lines. This worked as expected, at first.

          At frame 0 the green was on top and when I went to frame 1 it changed to white just as expected. Then when I went back to frame 0 the green was again on top but now only half of the digit was showing. I verified this by temporarily disabling layer 1. If I change layer 2 settings to number and then back to string lookup it resets. Layer 3 is the opposite of Layer 2 with 99 empty lines and then 10.0. I thought at first this might be the way it is rendering in Workshop, but when deploying to the screen I see the same result.

          Is having too many string lookups a problem? If so, is there a simple way to do what I want without having to add a bunch of custom images? Or using multiple objects on top of each other?
          Attached Files


          • #6

            I tried to open your project on our end. I tried to increase the height of the widget to 33, and somehow it works. However, this is something that still needs to look further into why this happened, and we are trying to figure it out.

            Best Regards.


            • #7
              I appreciate you looking into the issue. I had figured out that increasing the height fixed the issue as well but I hadn't had a chance to post a reply. This fixed my issue as the height increase isn't a problem. Thank you for the assistance.