Announcement

Collapse
No announcement yet.

PIXXI Arduino library?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PIXXI Arduino library?

    Hello.
    I bought a pixxiLCD-25P4 a few days ago.
    I immediately wrote some code in Arduino Compatible Environments and tried to upload it to Arduino, but I seem to have gotten the following error and could not write.

    PIXXI44_Serial_4DLib.h: No such file or directory
    Is there an Arduino library for PIXXI like the other one I use, GOLDELOX?
    I know of course that there are environments for developing with Visi and the like, but for my purposes this time, I want to develop with Arduino at all costs.

    Thank you very much for your help.

  • #2
    Hi,

    You can download the library from this Github repository: Pixxi-Serial-Arduino-Library

    I hope this helps.

    Best Regards

    Comment


    • #3
      Thanks for letting me know.
      I immediately tried to include the library and write the code to the Arduino, but it does not work.
      I'm attaching my code (which is a .ino file generated by Workshop4DE with some modifications and additions).
      The following is the code that I have modified and added.

      1. The code generated by Workshop4DE starts with "PIXXI44_", as in "PIXXI44_Serial_4DLib.h". So, I rewrote the file as follows.
      #include "Pixxi_Serial_4DLib.h"
      #include "Pixxi_Const4D.h"
      Pixxi_Serial_4DLib Display(&DisplaySerial);

      2. I added "Display." to the beginning of most functions, such as TimeLimit4D and img_Show. I got an error when I compiled the code, so I used Bigdemo as a reference and wrote the same code.

      3. The description of the joystick to control the display image has been inserted.

      The problem I am experiencing with my display is that when I connect it to the Arduino and turn it on, I get a "Drive not mounted..." message. and the image is not displayed.
      The 2GB micro SD card containing the image data (dat and gci) is inserted in the display.


      I apologize for the off-topic question.
      Please help me.
      Attached Files

      Comment


      • ivan_4d
        ivan_4d commented
        Editing a comment
        Hi,

        I will take a look at your project.

        Best Regards

    • #4
      Hi,

      The problem I am experiencing with my display is that when I connect it to the Arduino and turn it on, I get a "Drive not mounted..." message. and the image is not displayed.
      As you may have realized already, this means that the uSD card fails to mount.

      Assuming the SD card is properly mounted and there are no hardware issues, it is quite possible that your display's PmmC is not in uSD mode. You can change the PmmC of your display by following this article: How can I update my display to the latest PmmC and/or Driver?

      Be sure to select the latest PmmC for your display with "-u".

      If this doesn't work for you please let me know.

      Best Regards

      Comment


      • #5
        Thanks for answering so many times, ivan_4d!
        And sorry for the late reply.
        I manually selected "-u" in the PmmC Loader, loaded it, and it worked!
        It was very helpful. Thank you very much.

        Comment


        • #6
          Good day!

          You're welcome.

          Feel free to contact us again if you have any inquiries.

          Kind Regards

          Comment

          Working...
          X