Announcement

Collapse
No announcement yet.

Error when using Raspberry pi pico or ESP32

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when using Raspberry pi pico or ESP32

    Hello. I'd like to write again.
    I'm working on a program that sends data from openMV (machine vision module) to Arduino via serial communication, and based on the data, displays an arbitrary image on pixxiLCD-25P4 connected to Arduino.
    The program I made worked on the Arduino Mega and Arduino nano every.
    However, when I try to write this program to Raspberry pi pico and ESP32 with ArduinoIDE, it does not work.
    Here is the program I made and the error I got.
    I'm hoping someone can help me out.

    ■Raspberry pi pico error
     The library I used is earlephilhower/arduino pico (https://github.com/earlephilhower/arduino-pico).
     I get the message that the board has been written to. However, no image is displayed on the pixxiLCD-25P4.
     I verified the code in detail, and it seems that the following line causes the problem. However, I didn't have any good ideas on how to fix it.

     Pixxi_Serial_4DLib Display(&DisplaySerial);

     Incidentally, I get the same error message using the code I wrote for the μOLED-128-G2.

    ■ESP32 error
     When I try to compile, an error occurs and I cannot write to the board itself.
     I have included a screenshot of the error and a copy of the error message in a zip file.
     I was able to write the code I wrote for the μOLED-128-G2, but the image does not appear on the display. When I open the serial monitor, it seems to keep repeating the reboot.


    Thank you very much for your help.
    Attached Files
Working...
X