No announcement yet.

4D-UPA being seen only as a USB device

  • Filter
  • Time
  • Show
Clear All
new posts

  • 4D-UPA being seen only as a USB device

    I have a week old 4D-UPA that initially worked perfectly to programme my gen4-ulcd-43d the first time. But when I plugged it back in again (to edit the display) the PC flags up the USB Device not recognised error.
    I've spent the best part of 2 hours on two different laptops, deleting drivers, downloading drivers, following all the advice from previous posts on this forum. To no avail.

    The PC's will not see it as anything other than a USB device. If I try to force it to the updated driver it simply returns the error that the folder doesn't contain a compatible driver for my device (well it wouldn't if it thinks its a USB and not a UART device and I'm pointing at UART device driver)

    This should be so simple, I cannot imagine anything 'going wrong' with the hardware...

    Click image for larger version

Name:	USB.jpg
Views:	173
Size:	12.3 KB
ID:	76765

    I've worked with one of the IT guys at work to perform all activities that can normally cure this error. His conclusion was a hardware failure.

    Edit: error image added
    Last edited by Martin Barker; 1 September 2021, 09:01 PM.

  • #2

    Try to install the CP210x Universal Windows Driver. If this doesn't work you may try installing the CP210x VCP Windows.

    Be sure you uninstall the previous driver before installing another one.

    Click image for larger version

Name:	Drivers.png
Views:	113
Size:	67.2 KB
ID:	76785

    You can download these drivers to its download page: CP210x USB to UART Bridge VCP Drivers

    Best Regards


    • #3
      Hello Ivan, thanks for getting back to me. We tried both the Windows Drivers AND the Universal Windows Driver with no success.

      I cannot find the VCP Windows driver package you highlight, if I use your link, or navigate via the 4D Systems product page this is the list of downloads I see:

      Click image for larger version

Name:	Capture.JPG
Views:	116
Size:	37.1 KB
ID:	76789
      Its also worth noting that I have now had to buy a gen4-PA to complete this job and it works perfectly. (but so did the 4D-UPA originally)


      • #4

        I got no problem with the link that I sent. I tried to visit the link and, I navigate to the downloads tab of the page.

        To help you better, I downloaded the CP210x VCP Windows for you.

        Let me know if this one will work.

        Best Regards
        Attached Files


        • #5
          Hello again Ivan,
          The webpage difference must be a regional think, but thanks for the link.
          I'm afraid that it made no difference, the PC still sees it as a USB device. ☹️


          • #6
            What if you use a different cable between the computer and the 4D-UPA (and don't have your display connected)?


            • #7
              Here is an idea if you have run out of others, try what Mark said first though.

              Not our product. Not any affiliation to 4D at all.
              I have used this recently for something unrelated, and found it very useful.

              Be careful, but if you run this you should be able to see all the drivers on your system, and ones related to Silicon Labs etc. Follow the guide and you can remove them all (Silicon Labs ones), and then install the latest driver and hopefully it solves it. I have seen quirky behaviour before where an old driver can be installed, and updating did not fully remove the old driver, potentially due to the device still being plugged in etc, and so it was a hybrid of 2 versions together.

              Just an option for you to try.



              • #8
                Thanks Gents,

                Mark, after testing with my 2 high quality USB cables I resorted to extracting the huge tangle of old USB cables from a drawer... non worked.

                James, what a great app! if nothing else, thanks for that. I tried 3 different drivers from Si Labs site and non worked I'm afraid.

                We shouldn't loose sight of the fact that the Gen4 programming card I bought to replace this duff one works perfectly, it works with any of the 3 drivers from Si Labs site.

                This card worked initially, meaning it wasn't delivered duff, meaning it must be user error somewhere. Somehow I've killed it, which is OK, I just wish I knew how so I don't do it again.


                • #9
                  Sorry not much we can tell from here.

                  Good that the replacement you got works though.