Announcement

Collapse
No announcement yet.

Filetransfer Write failure with Invalid return code from Set Date / Time

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Filetransfer Write failure with Invalid return code from Set Date / Time

    hi ,

    I used WorkShop4 (4.7.0.11) with Gen4-uLCD-50DT .

    I want to use cable to tranfer my program file of .gci & .dat & .4XE to SD-card with Filetransfer. (Our situation is not easy to remove the SD card to update.)

    first I tranfer .dat file is successful , but when i tranf the .gci file ,

    it show the error message " Write failure " & "Invalid return code from Set Date / Time" ,

    then crush or no response.

    please help me to solve this problem, thanks .
    Last edited by KevinZhan; 8 October 2021, 03:31 PM.

  • #2
    Hi,

    Have you set the baudrate as documented in this forum, "File Transfer over serial(Programming) cable utility"? Also, does it work if you set the baudrate to the maximum baudrate of 115200? If not, try setting it to this baudrate and let me know if it works.

    Best Regards

    Comment


    • #3
      Hi Ivan,

      I tried a successful transfer today .

      but I still encountered the same problem.

      * Although the file name is display on the left , but the file can not found after re-reading the SD-card.

      ScreenShot as follow :


      Best Regards.​

      Comment


      • #4
        Hi Kevin,

        The screenshot is not attached correctly. It would be helpful if you give us more information. Like a screen capture showing the after connection, after the file transfer, after any errors, after clicking 'refresh', after any 'transfer complete' message. Also, it would be great if you'll send us a photo of your hardware setup.

        Best Regards

        Comment


        • #5
          Hi Ivan,

          The steps for the error are very simple.

          When I open "filetransfer", set the Baud rate to 115200, then click "Conect",

          select the file and click "Send file to Display", the error appears...

          There is no other information that I think is useful , just some divice version or display message in the attachment.

          Hope this helps .

          Best Regards
          Attached Files

          Comment


          • #6
            Hi,

            Can you share with us the screen copies of FileTransfer I mentioned? It will help a lot to give us enough ideas regarding the error. Also, make sure that you are using the File transfer that comes with the Workshop and, not the previous version.

            Best Regards

            Comment


            • #7
              Hi Ivan,

              How to check version of FileTranfer ? I have reinstalled the Workshop4 (4.7.0.11) .

              I have prepared a screenshot of the operation process, I hope this is useful for you.

              It’s also a pity that I don’t have any successful transmission experience this time.

              * png (7) It is not show the all file on the right side. normally it should like png(6).

              Best Regards
              Attached Files

              Comment


              • #8
                Are you running FileTransfer from the Tools tab in Workshop or from the Start menu?

                It normally comes from C:\Program Files (x86)\4D Labs\4D Workshop 4 IDE\DEP and if you hover over it Windows should tell you it is version 1.0.0.14

                From the change log:-
                Filetransfer 1.0.0.14
                Fixed Possible errors on non-English Locales.

                And the errors you are seeing are typical of those that 1.0.0.14 fixed

                So the first thing you need to do is ensure you are running 1.0.0.14, although that is what ships with Workshop 4.7.0.11, so that should not be the issue here.

                If that's not the issue can you try a few different files, to see if it's just that file that has issues? (You will need to restart file transfer each time)

                Can you email the file with problems to mark at 4dsystems dot com dot au?

                Can you also specify the country/locale set on your computer?
                Mark

                Comment


                • #9
                  Hi Mark,

                  I used FileTransfer tool throuh the workshop4 toolbar & FileTransfer is 1.0.0.14 .

                  I have try to change set of country to USA & Format the SD-card to FAT ,

                  Some file looks like transfer success.

                  But I get new error is "transfer aborted , in block=107 " with Service.gci in the attachment.

                  Please refer to attachment , thanks.

                  Best Regards
                  Attached Files

                  Comment


                  • #10
                    Unfortunately country and locale are quite different, you should be able to google up an answer or two, but it's still not completely clear to me why it affects us here.

                    In Win10 go, control panel, time & language, region, additional date, time & Regional settings, region, administrative, change system locale and note the current locale.

                    I'm pretty sure this is a locale issue because the size of service.gci is 914944(0xDF600) whereas on the display it shows 868096(0xD3F00). Note that the 0xF6 has been changed to 0x3F (an ASCII ?), this is typical of what the locale settings can inadvertedly play with.

                    It's not immediately apparent why it has been played with in this case as 1.0.0.14 should have fixed it completely.

                    So just let me know your locale and I'll hopefully be able to recreate it here.



                    Mark

                    Comment


                    • #11
                      Hi Mark ,

                      My locale is Taiwan , Traditional Chinese .

                      After change system locale to English , It's work now .

                      Thanks for your help !

                      Best Regards

                      Comment

                      Working...
                      X