Announcement

Collapse
No announcement yet.

playing videos from sd card on uOLED-96-G2 help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • playing videos from sd card on uOLED-96-G2 help

    hi guys i am new to this field of programming.
    i recently bought a few uOLED-96-G2. thinking all i need it to format the sd card and place in in to the uOLED-96-G2

    however i was greatly mistaken. and now i have been banging my head for a few months now and couldn't find any solutions

    I used the workshop to format my sd card and tried graphic composer to save a video on the sd card. but when i put it in the slot. nothing happens.

    i followed this Video Installation Instructions - YouTube. I believe it might be for another model, but thought it would work on my device. i was able to save a video on m card in the correct format.

    any help would be greatly appreciated.

    thanks guys for your help


  • #2
    Hi,

    Can you specify what video format and its size you are using? Have you tried to add a video in the video widget using the ViSi environment?

    Also, the SD card should be in the RAW format, which is used by the Goldelox display modules to save the graphics files.

    Best Regards

    Comment


    • kamz007
      kamz007
      Junior Member
      kamz007 commented
      Editing a comment
      hi.
      I was going to post a very long post, but thought i will have another go.
      i dont know what i was doing wrong however i have now got it to work.

      thanks for your help

  • #3
    Hi,

    You're welcome and, I'm glad you make it work.

    It would be better if you share it here in our forum about the process you did for it to work, so other users with the same issue could refer to this forum post.

    Best Regards

    Comment


    • kamz007
      kamz007
      Junior Member
      kamz007 commented
      Editing a comment
      no problem
      i went through the ViSi environment and used the video from widgets. here is my code:

      #platform "GOLDELOX"

      // Program Skeleton 1.0 generated 07/01/2022 02:54:29

      #inherit "4DGL_16bitColours.fnc"

      #inherit "VisualConst.inc"

      #inherit "NoName4Const.inc"

      var frame;

      func main()
      // Uncomment the following if uSD images, fonts or strings used.

      print("Starting\n") ;
      while(!media_Init())
      putstr("Drive not mounted...");
      pause(200);
      gfx_Cls();
      pause(200);
      wend

      repeat

      for(frame := 0; frame < 7925; frame ++)
      // Video1 1.0 generated 07/01/2022 02:55:36
      media_SetAdd(iVideo1H, iVideo1L) ; // point to the Video1 image
      media_Video(0, 0) ; // show video
      next

      forever
      endfunc

      the frame is what size your video is and // Video1 1.0 generated 07/01/2022 02:55:36
      media_SetAdd(iVideo1H, iVideo1L) ; // point to the Video1 image
      media_Video(0, 0) ; // show video

      is the code i pasted

  • #4
    Hi,

    Thank you for sharing your code in the forum.

    If you have another inquiry, you can raise a ticket in our 4D Systems Helpdesk.

    Best Regards

    Comment

    Working...
    X