Announcement

Collapse
No announcement yet.

70DCT-CLB Display not Booting up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 70DCT-CLB Display not Booting up

    Hi I have a device that with a custom power+controller board that displays sensor data on the 70DCT-CLB screen. My current problem is that when hooked up to my device the screen does not boot up ( I am 99% this is the case, however it could be that its just showing a blank screen).

    The controller I am using is a ATMEA32U4 to communicate information to the screen and it is programmed via Arduino as ISP.

    I do not believe the screen is the problem, however once I describe my issue and what I have done to troubleshoot perhaps someone can help me into where to start looking next.

    I do not think it is the screen because I have connected a brand new screen to my device with the same result. The screen does not have any green words on the top left corner by the way, nor does it say "no disk mounted". Additionally, powering the screen through USB directly from my pc it works fine. Through Workshop I have COMMs communication OK and I can switch between forms and all the input/outputs work.

    I have checked all my connections, and looms for continuity and resistance and everything is looking OK, including continuity to the pins/connections on my PCB/.board and to the controller component.

    What I find very strange is that when I check for voltage on pins 1 and 27 on the back of the screen on the 30-Way FCP pins I am reading 5V. However using an oscilloscope the supply voltage reading is strange and unsteady. The TX line on my scope looks fine.

    I do not understand how the screen can be reading 5V and not turning on. I would have thought that the screen would turn on but not input/outut nor programming communication would have worked, but the screen remains black.

    I have switched out all my hardware for new components (excluding the controller component) and still having the same problem.

    Any guidance would be appreciated. thank you

  • #2
    Hi

    Welcome to the Forum,

    It sounds like the display is being held in Reset. If you have have Reset connected to a GPIO of the custom controller it should be HIGH after the reset procedure is done, something like this in Arduino code,

    Code:
    pinMode(33, OUTPUT);
    digitalWrite(33, LOW);
    delay(150);
    digitalWrite(33, HIGH);
    delay(3500);
    I would suspect if using code like the above then it is reversed eg HIGH and then LOW.

    I hope this helps

    Best regards

    Paul

    Comment

    Working...
    X